MA5

Overview

The Mobile Alarming 5 (MA5) software is a client / server type application which provides communications from Microscan via email and SMS TXT messages and communication back to Microscan via SMS TXT messages.

With SMS TXT messages it is possible to 'Get' and 'Set' values within Microscan including Tag and Recorder Line values and acknowledging alarms.

The MA5 Client must be installed on each PC running Microscan whilst the MA5 Server may be installed either on a PC running Microscan or on any networked PC having read / write privileges on the respective Microscan PC's.

Below is a simple schematic of the Mobile Alarming 5 (MA5) installation on a single PC.

View schematic for Network Installation
Slave Installation

where the 'Email' requires access to an SMTP server and the 'SMS TXT' is a Siemens MC35 GPRS modem connected to the serial port of the PC.

There are 4 main functions that can be performed by the Mobile Alarming software:

  1. Notification of a Microscan alarm via an email and / or an SMS TXT message.
  2. Acknowledgment of a Microscan via a SMS TXT message.
  3. Getting the value from Microscan. *
  4. Setting a value in Microscan. *

* The Microscan values that can be read or written to are:

  • Tag and Line value
  • Alarm Setpoint
  • Alarm Delay
  • Alarm Enabled.

Getting started with the Mobile Alarming software.


MA5 Getting Started

Overview>Getting Started

Prerequisites

  1. The Mobile Alarming software requires Microsoft .Net to be installed prior to installation.

Before Installing the Mobile Alarming 5 (MA5) software consider the following:

  1. It is beneficial, but not essential, to have both email via an SMTP server and the SMS TXT messages via the Siemens MC35 modem available as it provides a dual system for alarm, warning and error messages.
  2. If security is an issue so that it is preferred that the Microscan PC is not able to have access to an SMTP server then consider installing the MA5 Server component on to a centrally located PC/server that is able to access the SMTP server. If this is done then the MA5 Client Data Folders must be added to the MA5 Server configuration. The MA5 Server must have full read/write access to all the MA5 Client Data Folders.
  3. If the MA5 Server is polling the MA5 Client Data Folders from across the network and the network has failed or the Microscan PC can not be found on the network then Microsoft Windows will momentarily slow the PC as it tries to find these folders. For this reason it may be considered good to not install the MA5 Server on a critical mission server.
  4. Once the decision has been made where to install the MA5 Server, install both the MA5 Client and the MA5 Server and complete the setup.

Mobile Alarming 5 Licensing

  1. The MA5 Server does not require a licence unlock code to operate but our licensing does require it to operate with at least one MA5 Client.
  2. The MA5 Client does require a licence to operate. This is provided as part of the Microscan licensing.

Email SMTP Server

  1. If you a larger organization with your own mail server then consider using an in house SMTP server as it will be quicker to internal addressees and will save internet traffic. Microsoft's Exchange Server comes complete with an SMTP server.

Siemens MC35 Modem

  1. The Siemens MC35 modem is designed for the vodafone network and comes without a SIMMS card.
  2. It is recommended to select a monthly plan to avoid problems such as the SMS TXT messages not working if the pre-pay was not topped up.
  3. Before putting the SIMMS card into the MC35 test it in a regular phone first. Make sure it is NOT password protected as this will stop it from initializing in the MC35.

Please refer to the following links for details on the configuration of the MA5 Client and the MA5 Server:
MA5 Client
MA5 Server


Untitled Document

When using the MA5 to reference values within Microscan for Get, Set and Logging use the following syntax.

Note that the references shown below are not case sensitive.

 | Microscan Reference Examples
Item | for Recorder Lines | for Tags
Current Value (Option 1) | P1L1 | T1
Current Value (Option 2) | P1L1.Value | T1.Value
Alarm Enabled | P1L1.AL.ON | T1.AL.ON
Alarm 1 Setpoint | P1L1.AL1.SP | T1.AL1.SP
Alarm 1 Delay | P1L1.AL1.Delay | T1.AL1.Delay
Alarm 2 Setpoint | P1L1.AL2.SP | T1.AL2.SP
Alarm 2 Delay | P1L1.AL2.Delay | T1.AL2.Delay


MA5 - How it works: Roster, Shifts and Alarm Groups

Overview>Roster, Shifts and Alarm Groups

How it works: Roster, Shifts and Alarm Groups

  • The Alarm Group is the reference that Microscan uses when assigning alarms for the Mobile Alarming 5 program. Up to 16 Alarm Groups may be created giving the ability to divide the site into various areas of responsibility and importance.
  • Within the MA5, each Alarm Group is assigned one of the many Rosters which may be created.
  • Each Roster includes a sub section for each shift which has been created.
  • To each Roster\Shift is assigned the users that are to be notified in the event of an alarm.

The following diagram illustrates the steps that happen to determine which users should receive a new alarm message:

Hint: If the users are being changed on a regular basis such as weekends or shut downs then create a new Roster and simply re-assign the Roster to the Alarm Group instead of changing the users within each Roster/Shift.


MA5 - Life of an Alarm

Overview>Life of an Alarm

When an alarm is created by Microscan it is processed by the MA5 Client program and sent to the respectively assigned users via the MA5 Server program.

Whilst all alarms may be acknowledged a new alarm can be required to be acknowledged by one of two ways:

  1. The alarm originates from a Microscan "Latched" alarm which requires clearing or
  2. The alarm message begins with an exclamation mark "!".

If the alarm originates from a Microscan "Latched" alarm then the MA5 Client program will add an exclamation mark "!" to the beginning of the alarm message if not already existing.

This means that when a user receives a new alarm notification they can determine if it should be acknowledged by looking for the exclamation mark "!" at the beginning of the alarm message.

The following is a typical alarm SMS TXT message:

To acknowledge an alarm a user forwards the alarm SMS TXT message to the Siemens MC35 modem.

The MA5 Server forwards the message on to the MA5 Client that originated it.

The MA5 Client receives the message, accepting the acknowledgement, clearing the Microscan alarm if applicable and then returning a confirmation message to the user.

If the alarm has been acknowledged or cleared already then the user is sent a message to that effect.


MA5 - Microscan Get

First the user must be enabled to Get Data from Microscan.

To get the value of a Microscan reference send an SMS TXT message to the Siemens MC35 Modem similar to the one below:

where:

(M1) | Is the Client ID and must be inside brackets.
(Get) | Is the command that to get the data.
T1 | Is the Microscan Reference of the data required.

The MA5 will return an SMS TXT message similar to the one below:


MA5 - Microscan Set

First the user must be enabled to Set Data from Microscan.

To get the value of a Microscan reference send an SMS TXT message to the Siemens MC35 Modem similar to the one below:

where:

(M1) | Is the Client ID and must be inside brackets.
(Set) | Is the command that to set the data.
T1 | Is the Microscan Reference of the data required.

The MA5 will return an SMS TXT message similar to the one below:

Each time the MA5 is used to change a setting in Microscan an entry will be added to the Audit Log for reference as shown below where the top 3 entries are made by the MA5 and the lower 3 entries are made by a user logged in to Microscan locally.


MA5 Client Overview

Overview>Getting Started>Client Overview

The MA5 Client provides the communications interface between Microscan and the MA5 Server.

It must be installed on the same PC as Microscan Version 5.

Once the MA5 Client has been installed, run Microscan Version 5 and then start it from the icon [image] that appears on the Desktop and complete the Setup. Once the MA5 Client has been started then it will automatically start and stop with Microscan.
MA5 Client
MA5 Client Setup - General
MA5 Client Setup - Operation
MA5 Client Setup - Users
MA5 Client Setup - Shifts
MA5 Client Setup - Rosters
 MA5 Client Setup - User Assignments
MA5 Client Setup - Alarm Groups
MA5 Client Setup - Alarms
MA5 Client Setup - Logging
MA5 Client Setup - MA5 Server


MA5 Client Overview

Overview>Getting Started>Client Overview>MA5 Client

This is the MA5 Client main form:

The MA5 Client tracks all of the communications that pass through it as shown above, each one being given a new "Ref".

It also provides for various reporting options from the "Report" menu.

When the MA5 Client is first run it is important to complete the Setup from the "Setup" menu:
General
Operation
Users
Shifts
Rosters
User Assignments
Alarm Groups
Alarms
Logging
MA5 Server


MA5 Client Setup - General

Overview>Getting Started>Client Overview>MA5 Client>General Setup

This is the MA5 Client "General" setup tab:

The General setup has the following properties:

Company Name | Enter your company name.
Company Contact | Enter the contact name. This will appear on some TXT messages if the message is not recognized so it is good to include a contact email address or phone number.
Keep log files for (months) | Enter the number of months to keep the log files before deleting them.
Email Daily Reports to | Enter the email addresses to which the daily reports are to be sent. Separate addresses with a semi-colon ";"


MA5 Client Setup - Operation

Overview>Getting Started>Client Overview>MA5 Client>Operation

This is the MA5 Client "Operation" setup tab:

The Operation setup has the following properties:

Password to access this area Enter the password to access this setup area.


MA5 Client Setup - Users

Overview>Getting Started>Client Overview>MA5 Client>Users

This is the MA5 Client "Users" setup tab:

There is no limit to the number of users you can add, only that each user must have a unique name consisting of alpha-numeric characters only.

The User setup has the following properties:

Name | Enter your company name.
Phone / Email | Enter the contact name. This will appear on some TXT messages if the message is not recognized so it is good to include a contact email address or phone number.
Enable for Alarms | Set to "Yes" to allow the user to acknowledge alarms. Otherwise set to "No". Note that a user may receive alarms even if they are not enabled to acknowledge them.
Enable for Get Values | Set to "Yes" to allow the user to query (read) Microscan values. Otherwise set to "No".
Enable for Set Values | Set to "Yes" to allow the user to change (write) Microscan values. Otherwise set to "No".
Enable for Logging | Set to "Yes" to allow the user to accept MA5 Logging SMS TXT messages from another MA5 installation. Otherwise set to "No".


MA5 Client Setup - Shifts

Overview>Getting Started>Client Overview>MA5 Client>Shifts

Please refer to How it works: Rosters, Shifts and Alarm Groups

This is the MA5 Client "Shifts" setup tab:

There is no limit to the number of shifts you can add.

The Shift setup has the following properties:

Name | Enter a descriptive name for the shift.
Start | Enter the shift start time in the 24 hour standard format of HH:MM as shown above.
Stop | Enter the shift stop time in the 24 hour standard format of HH:MM as shown above.
Sat, Sun, Mon, Tue, Wed, Thu, Fri | Select the days of the week that this shift is to be enabled for.


MA5 Client Setup - Rosters

Overview>Getting Started>Client Overview>MA5 Client>Rosters

Please refer to How it works: Rosters, Shifts and Alarm Groups

This is the MA5 Client "Rosters" setup tab:

There is no limit to the number of Rosters you can add.

The Roster setup has the following properties:

Name Enter a unique name for the Roster.


Untitled Document

Overview>Getting Started>Client Overview>MA5 Client>User Assignment

This is the MA5 Client "Users" setup tab:

There is no limit to the number of users you can assign to each roster-shift.

Add, remove and position the users as required, when finished click on the "View Report" link to see the complete schedule.


MA5 Client Setup - Alarm Groups

Overview>Getting Started>Client Overview>MA5 Client>Alarm Groups

Please refer to How it works: Rosters, Shifts and Alarm Groups

This is the MA5 Client "Rosters" setup tab

Up to 16 Alarm Groups can be created.

The Alarm Group setup has the following properties:

Name | Enter a unique name for the Alarm Group. This will be automatically updated to the Microscan configuration.
Roster | Select the required Roster.
Wait mins | Applies only to those alarms which require to be acknowledged and represents the time delay between sending the alarm message to the SMS TXT users. If an SMS TXT user acknowledges the alarm by forwarding the message back to the Siemens MC35 Modem then it will not be sent to the remaining users. Refer to the Life of an Alarm


MA5 Client Setup - Alarm Folders

Overview>Getting Started>Client Overview>MA5 Client>Alarms

Please refer to How it works: Rosters, Shifts and Alarm Groups and to the Life of an Alarm

This is the MA5 Client "Alarm Folders" setup tab

The Alarm Folders setup is divided in to two distinct areas:

1. Active Folder:
This is the folder that recieves the alarm text messages from Microscan located on the PC where the MA5 Client is installed.
It has the following properties:

Alarm Folder | Read only. Displays the Microscan Alarm Folder.
Ackn to Clear Microscan Alarms | If this is enabled then the MA5 Client will clear the respective Microscan Alarm when it is acknowledged by an SMS TXT message.

2. Slave Folders:
These are a list of Microscan Alarm folders on other Microscan PC's that have not yet been licenced for an MA5 Client but do require having their alarm messages being sent.
This is only possible on sites where there is more than one Microscan PC.
A Microscan PC configured as an MA5 Slave is not able to be interogated by the MA5 Software nor are their Microscan Alarms able to be acknowledged by the MA5 Software. A Microscan PC configured as an MA5 Slave is only able to send alarm messages.

The Slave Folders have the following properties:

Ref Name | Enter a descriptive but short reference name for the respective Microscan PC. This name will be suffixed to the outgoing messages so that it is easy to identify which PC it originated from.
Enabled | Specifies if this PC / Folder is enabled to be checked for alarm messages.
Folder | Select the Microscan Alarms folder on the respetive Microscan PC. Either mapped or unc folders may be used.


MA5 Client Setup - Logging

Overview>Getting Started>Client Overview>MA5 Client>Logging

MA5 Logging can be used in two ways:

  1. Sending regular logs of Microscan data to an email user and/or an SMS TXT message user. This is particularly useful during commissioning and testing.
  2. Sending regular logs to another Microscan/MA5 installation auto updating the respective Microscan values.

This is the MA5 Client "Logging" setup tab:

There is no limit to the number of logs you can set up.

Each Log has 3 main areas of configuration as depicted by the "General", "Msgs to Log" and "Send To" tabs shown above.

1. General Tab (as shown above)

Name | Enter a name the describes the Log
Send Log every (hrs:mins) | Enter the time duration between sending logs in the standard hh:mm format.
Start end at (hrs:mins) | Enter the time of day which the MA5 Client program should use to calculate the next send time.

2(a). Msgs to Log - NOT to another Microscan/MA5 installation

There is no limit to the number of Microscan values that can be logged.

Log to another MA5 | This is set to "No".
Log From | Enter the Microscan Reference to be logged.

2(b). Msgs to Log - To another Microscan/MA5 installation

There is no limit to the number of Microscan values that can be logged.

Log to another MA5 | This is set to "No".
Log From | Enter the Microscan Reference to be logged.
Log To | Enter the Microscan Reference to be logged to. This is the target reference on the Microscan/MA5 installation being logged to.

3. Send To Tab

There is no limit to the number of users that the log can be sent to.

Add in the users as required.


MA5 Client Setup - MA5 Server

Overview>Getting Started>Client Overview>MA5 Client>MA5 Server

This is the MA5 Client "MA5 Server " setup tab:

The MA5 Server setup has the following properties:

MA5 Client Data Folder | Read only. Displays the MA5 Client Data Folder. This must be included in the MA5 Client Folder list.
Scada Ref for 5 min time-out alarm | Enter a Microscan Reference for the time-out alarm. If set the value of the reference will be set to 0 if there are no files in the MA5ClientData folder older than 5 minutes. If there are some files older than 5 minutes then it is deemed that the MA5 Server program is no longer servicing this folder and the reference will be set to 1. It would be good if this reference was a alarmed within Microscan and connected to an external alarm or auto dialer.


MA5 Slave Overview

Overview>Slave Installation

When the MA5 Slave program is installed on a Microscan PC there is no configuration to do.
Simply run the program from the link provided during the installation process found at
Start\Programs\Microscan Software\Mobile Alarming 5\MA5 Slave.

The MA5 Slave program has been designed to automatically start and stop with Microscan and will keep a running record of the last 100 activities as shown below.

For an overview of how the MA5 Slave would be deployed on a site please refer to MA5 Slave Installation.


MA5 Server - Overview

Overview>Getting Started>Server Overview

The MA5 Server provides the communications interface between the Microscan/MA5 Client(s) and the email and SMS TXT services.

It may be installed on the same PC as the MA5 Client program or on a network PC, refer to the Network Installation.

Once the MA5 Server has been installed, start it from the icon [image] that appears on the Desktop and complete the Setup.
MA5 Server
MA5 Server Setup - General
MA5 Server Setup - Client Folders


MA5 Server - Main Page

Overview>Getting Started>Server Overview>MA5 Server

This is the MA5 Server main form:

The MA5 Server tracks details of all communications that pass through it as shown above, each one being given a new "Ref".

It also provides for various reporting options from the "Report" menu.

When the MA5 Server is first run it is important to complete the Setup from the "Setup" menu:
General
Client Folders


MA5 Server - General Setup

Overview>Getting Started>Server Overview>MA5 Server>General Setup

The following is an example of the MA5 Server General Setup:

The following is a description of the General options:

Company Name | Enter your company name.
Company Contact | Enter the contact name. This will appear on some TXT messages if the message is not recognized so it is good to include a contact email address or phone number.
Gsm Modem Comm Port | Set the Comm Port number that the Siemens MC35 Modem is installed on. To disable set to 0
Email Smtp Setup | This runs the SMTP configuration program.
Email Daily Reports to | Enter the email addresses to which the daily reports are to be sent. Separate addresses with a semi-colon ";"
Keep log files for (months) | Enter the number of months to keep the log files.
Auto run when Windows starts | Set if the MA5 Server is to auto start with windows (recommended)
Auto close with Windows | Set if the MA5 Server will auto close with windows (recommended). If set to no, the PC will not be able to auto restart.
Password to close | Enter the password to manually close the MA5 Server
Password to access this area | Enter the password to access the MA5 Server Setup area.
Scan Client Folders (secs) | Enter the number of seconds between scanning the Client Folders.
Send Folder + Modem Errors to | Enter the email addresses and phone numbers that any error messages should be sent to. Separate addresses with a semi-colon ";"


Server Setup- Client Folders

Overview>Getting Started>Server Overview>MA5 Server>General Setup

The following is an example of the MA5 Server Client Folders Setup:

There is no limit to the number of Client Folders that may be added.
Each Client Folder must have a unique "Client ID" name and must allow read/write access.

The properties of the Client Folders setup are:

Client ID | The Client ID must be unique and must consist of alpha-numeric characters. It is a good idea to keep it short and cryptic as it is used in returning SMS TXT messages to identify which Microscan application is to be addressed.
Folder | Set the respective folder. This will typically be "C:\MicroScan\MA5ClientData" on the Microscan PC. Make sure to click on the "Test" button to confirm that the MA5 Server has read/write access to this folder. If unsure of the folder go to the MA5 Client program and the folder will be displayed on the MA5 Server tab in the setup area.
Enabled | Typically this would be set to "Yes". However if the folder can NOT be found on the network due to a planned shutdown etc then it is recommended that this is set to "No" so that Microsoft Windows will not momentarily slow the PC as it tries to find the folder.
Users | This is a read only facility and displays the users that the respective MA5 Client applications have enabled. The MA5 Server uses this list of Users to determine if the incoming SMS TXT message is from a known user. If not then it will not forward the message on but will instead return a SMS TXT message advising the sender that they are not authorized and that the should contact the "Company Contact".


MA5 - Data/Log Files

MA5 Client program

The MA5 Client program data/log files are saved to the following folders:

  1. 'C:\Documents and Settings\All Users\Application Data\MA5Client\Data' if Microscan is NOT installed and
  2. 'C:\MicroScan\[jobname]\data\MA5Client' when Microscan is installed.

Note that if Microscan is not installed then an independent backup of the MA5 Client Data/Log files is required.

MA5 Server program

The MA5 Server program stores its data/log files in the following folder:

  1. 'C:\Documents and Settings\All Users\Application Data\MA5Server' and sub-folders.

Note that an independent backup of the MA5 Server Data/Log files is required.


Untitled Document

The following diagram illustrates the flow of the files during the normal operation of the MA5.

Note that each program (except for the Get/Set functions) is separated by simple text files.

This makes it easier to see where a problem may exist and to prove just what is happening, for example that read / write access is enabled correctly for the folder.

Also it is possible to stop one of the programs and view the buildup of unprocessed files in the respective folder.

The files in the Microscan Alarm Folder are simple text files which include details of the alarm in a pre-set format. When the MA5 Client scans this folder and finds a new alarm message it opens the file, extracting the details and the deletes it.

The files in the MA5 Client Data Folder are also simple text files each of a specific format as follows:

  1. ToEmail*.txt - This is created by the MA5 Client program and is being sent to the MA5 Server program for sending via email.
  2. ToGsm*.txt - This is created by the MA5 Client program and is being sent to the MA5 Server program for sending via SMS TXT message.
  3. FromGsm*.txt - This is created by the MA5 Server program following the receipt of an SMS TXT message and is being sent to the MA5 Client program for processing.
  4. Users*.txt - This is created by the MA5 Client program and is being sent to the MA5 Server program to update the currently configured MA5 users. This is sent each time the MA5 Client program starts and each time the MA5 Client setup is changed.


MA5 - Setup Files

MA5 Client program

The MA5 Client program setup files are mirrored to two folders:

  1. 'C:\Documents and Settings\All Users\Application Data\MA5Client\Setup' is the master folder and
  2. 'C:\MicroScan\[jobname]\setup\MA5Client' when Microscan is installed.

When Microscan is installed the setup files are mirrored from 1. to 2. However on startup if the files in 2. are different then they are copied from 2. to 1. so as allowing for a Microscan restore process.

Note that if Microscan is not installed then an independent backup of the MA5 configuration is required.

MA5 Server program

The MA5 Server program stores its setup files in the following folder:

  1. 'C:\Documents and Settings\All Users\Application Data\MA5Server' and sub-folders.

Note that an independent backup of the MA5 Server configuration files is required.


MA5 - Sample Reports

The following is a sample report. A similar format is available from both the MA5 Client program and the MA5 Server program.

There is a an option to produce a daily report or a monthly report. The daily report can be configured to be sent automatically once a day.


MA5 - Sample Messages

Below is a sample alarm email:

Below is a sample warning email:

Below is a sample error email:

Below is another sample error email:


MA5 Network Installation

Overview

Below is a simple schematic of the Mobile Alarming Network Installation.

where the operation is the same as for the Single PC Installation.


Slave Installation

Overview

Below is a simple schematic of the Mobile Alarming Slave Installation.

where the operation of the MA5 Server and MA5 Client is the same as for the Single PC Installation excepting that Microscan may or may not be installed on the same PC as the MA5 Client program.

However in the Slave Installation the MA5 Client has been configured to scan "Slave Folders" instead of the local alarm folder.

Slave folders are Microscan Alarm folders on networked Microscan PC's that have been configured to run the MA5 Slave program.
The MA5 Slave program co-ordinates the naming of the Microscan Alarm Groups on the networked PC's to be the same as those set by the MA5 Client program.

This configuration requires only one MA5 licence to service multiple Microscan PC's, the limitation being that the Microscan alarms can not be acknowledged nor can the "Get", "Set" or "Log" commands be used to access Microscan.